Fixed | Open Arko Ai in sketchup, its blank (version1.0.6)

I can’t see anything in the layout window (version1.0.6),and I can not press the RENDER button either, my sketchup version is 22.0.316

Hmmm let’s see if we can help you out…

Can you copy paste the whole ruby console log?

Or send it to me in a direct message?

Okay thank you, this is very helpful. It looks like Arko is failing to save the image of the current view.

This image file is saved to the location given if you type this in the ruby console


If that path comes back okay, then we’ll have to look a little closer.

On the next update I can push some code that gives us more information.

Also, are you on windows or mac?

I’m on windows

Okay, this is the issue. We should be able to push a fix for this today.

I’ll update here when an update is available. Thank you for the feedback.

Hello @zangtu

I just released a new update. You can find the latest installer on the website here:


If you could install this one and run Arko that’d be greatly appreciated. I don’t think it will solve the issue, but it should give us more information in the Ruby Console for figuring out the issue.

Thank you for your updating.however, it is still blank… :thinking:

So I’ve been doing some research on this issue and from the SketchUp forums there seems to be some issues with certain characters and spaces and things in file paths…

I’m not exactly sure what the cause is, so we’ll have to do some more significant testing.

In the meantime, I published a new version 1.0.8 on the website. You can find the latest installer here: INSTALLER

This version has a message in the ruby console that says "saving current view to: ..." that would be helpful if you send a screenshot of.

If we can’t find a solution after some testing, we may need to open a ticket with SketchUp, as we have many, many users who do not have this issue, so it may be a bug in the API.

More to come, and thank you for your patience.

Hello @zangtu,

I believe we have solved this issue in 1.0.9. It seemed that there was a problem with the file paths, so we updated to use a different path.

Please let us know if you still have this issue.



This issue has been solved! Thank you for you updating!!

1 Like